Подключение обработки заполнения.

Пример подключения обработки заполнения.

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("3.0.3.43");
ПараметрыРегистрации.Информация = НСтр("ru = 'Синоним обработки.'");
ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
ПараметрыРегистрации.Версия = "1.04";
ПараметрыРегистрации.Назначение.Добавить("Документ.ЗаказПокупателя");

Команда = ПараметрыРегистрации.Команды.Добавить();
Команда.Представление = НСтр("ru = 'Синоним обработки.'");
Команда.Идентификатор = "ИмяОбработки";
Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
Команда.ПоказыватьОповещение = Ложь;

Возврат ПараметрыРегистрации;

КонецФункции

В модуле формы:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

Если Параметры.Свойство("ОбъектыНазначения") и
Параметры.ОбъектыНазначения <> Неопределено Тогда
ЗаказПокупателя =
Параметры.ОбъектыНазначения[0];
ИмяФормыВладельца = Параметры.ИмяФормы;
КонецЕсли;

КонецПроцедуры

Уроки на все случаи жизни

Нажимайте кнопки! Делитесь информацией с друзьями! Нажимайте кнопки! Делитесь информацией с друзьями!

Получайте информацию о новых акциях и новостях на свою электронную почту!

 

Введите адрес электронной почты:

 

 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Разместить ссылку на свою статью